Inventive Dingo forums Inventive Dingo forums
News:
 
*
Welcome, Guest. Please login or signup. August 22, 2014, 07:51:17 am


Login with username, password and session length


Pages: [1]
  Print  
Author Topic: Server Bug Again...  (Read 1936 times)
Stixsmaster
Space cadet
*
Posts: 24


View Profile WWW
« on: January 31, 2009, 06:05:15 am »

Hey all,

I found that I can clearly host for the game and well I wouldnt really call this a bug but the game still seems to struggle much at sending a bind to a socket or sumthing when I host...and I have no firewall restrictions or anything for it...

How do I know that no firewalls are restricting it or anything because I know how I can get the game to host a server properly...for peeps to join because I already did it once with a friend I gave my guest pass to...

The only way I am able to properly host a game most of the time...sumtimes it gives this socket binding error still...and well the only way is to shut game down when I get the error completely and then reload it up again and then try to instantly host real quick after it loads and most of the time it works...

But if I leave the server for sum reason any reason and stay in the game...say I am altering sum option settings or sumthing...then I try to host again it gives this error...

I have this error popup when I tried how I said I could get hosting a server to work MOST of the time...hence the MOST...

I also noticed that when I open up my steam menu to my games tab...and then I right click the game and click on "Properties" then click on the "Set Launch Options" button and add -dedicated to it and then try to launch the game...all it does is real quick when I view from my taskmenu run the program for like a second then shut it down...without giving any errors or anything...

---Stixsmaster
Logged
Minus
Destroyer of Worlds
***
Posts: 83



View Profile
« Reply #1 on: January 31, 2009, 06:40:58 am »

This has been posted about before. The only way to fix it is to continue trying.
Logged

My SteamID - Let's have a game!
Mayhem Intergalactic Steam Group - Let's have a bigger game!
Chris
Administrator
*****
Posts: 408


Developer


View Profile WWW
« Reply #2 on: January 31, 2009, 12:31:34 pm »

A quicker workaround is to change the port number (on the create server screen). Just add 1 to it or something. The catch, of course, is that whatever port you host on must be forwarded (assuming you have a router) and allowed through any firewalls.

The cannot bind to port error is time-dependent. What happens is that the operating system is reserving the port that you're trying to host on, usually because someone was connected to it and the OS hasn't received a notification that the connection was properly severed. All you have to do is wait and try again; quitting and re-starting the game shouldn't be necessary.

I also noticed that when I open up my steam menu to my games tab...and then I right click the game and click on "Properties" then click on the "Set Launch Options" button and add -dedicated to it and then try to launch the game...all it does is real quick when I view from my taskmenu run the program for like a second then shut it down...without giving any errors or anything...

Yeah, it's still broken. I thought I'd fixed it, but noticed just before release that it wasn't really. Sad  I decided to just omit it from the patch rather than hold up all the other critical bug fixes. It'll hopefully be fixed in the next patch.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM